Unable to login on App
Incident Report for Geckoboard
Resolved
This issue is now resolved. Thank you for your patience and please reach out to us at support@geckoboard.com if you're still unable to access the App.
Posted Sep 17, 2018 - 13:36 UTC
Update
You may have trouble both logging in to Geckoboard and even if you were already in. We're working to resolve this at the earliest.
Posted Sep 17, 2018 - 13:18 UTC
Investigating
We are currently experiencing technical difficulties logging in to our application. Our team is actively working to fix the issue. We hope to have this resolved soon.
Posted Sep 17, 2018 - 12:59 UTC
This incident affected: Web Application.