Customer Support paused for helpdesk maintenance
Incident Report for Geckoboard
Resolved
This incident has been resolved.
Posted Jun 19, 2019 - 09:08 UTC
Monitoring
The maintenance has been completed successfully. You can reach out to our customer support team and receive speedy replies as per usual! 🙂
Posted Jun 19, 2019 - 08:42 UTC
Investigating
Our support helpdesk (both chat and email) are currently in maintenance. We should be back up and replying to your queries soon. We'll share another update in 30 minutes.
Posted Jun 19, 2019 - 08:12 UTC
This incident affected: Support team chat tool and Support team message delivery.