Issues with some widget updates
Incident Report for Geckoboard
Resolved
Problem solved. If you’re still having any issues, please message us for help at support@geckoboard.com.
Posted Nov 06, 2018 - 11:52 UTC
Investigating
We’re investigating a problem affecting some widgets and causing them not to update. We’ll keep you posted.
Posted Nov 06, 2018 - 11:29 UTC
This incident affected: Web Application.