Unable to access Geckoboard app
Incident Report for Geckoboard
Resolved
The loading issues with the application have been resolved. Enjoy!
Posted Sep 17, 2018 - 17:12 UTC
Monitoring
We've fixed the issues affecting our application and will continue to monitor the situation.
Posted Sep 17, 2018 - 16:25 UTC
Investigating
We are currently experiencing technical difficulties accessing our application. Our team is actively working to fix the issue. We hope to have this resolved soon.
Posted Sep 17, 2018 - 15:55 UTC