Investigating issues with editing Spreadsheet widgets
Incident Report for Geckoboard
Resolved
Problem solved. You should be able to edit Spreadsheets widgets seamlessly again. Please get in touch (support@geckoboard.com) if you still notice any issues. Sorry for the disruption and Happy Friday!
Posted Oct 18, 2019 - 11:21 UTC
Investigating
We are currently investigating issues with our Spreadsheet integration, particularly when editing widgets to remove a comparison visualizations. We'll provide updates as we learn more.
Posted Oct 17, 2019 - 17:59 UTC