New Account Dashboard Issues
Incident Report for Geckoboard
Resolved
The issue affecting newly created accounts should now be resolved. Our engineering team will continue to monitor the situation.
Posted Jun 15, 2017 - 22:10 UTC
Investigating
Our engineers are investigating an issue with newly created accounts. We'll be publishing another update within the hour.
Posted Jun 15, 2017 - 21:09 UTC