Spreadsheets loading issues
Incident Report for Geckoboard
Resolved
The Spreadsheets issue is fixed! Have a wonderful day! :)
Posted Oct 28, 2019 - 15:32 UTC
Monitoring
Hi again! We've fixed the Spreadsheets loading issue and will continue to monitor to make sure all is well. :)
Posted Oct 28, 2019 - 14:53 UTC
Investigating
Hi! We’re aware of some loading issues with the Spreadsheets integration. We're working on this and will update you soon!
Posted Oct 28, 2019 - 14:44 UTC