Issues with processing Amex cards
Incident Report for Geckoboard
Resolved
We're can now confirm that we can accept Amex cards again. If you tried to make a payment over the weekend but failed, please retry and the payment should now go through. If you have any issues, please just contact us support@geckoboard.com. Have a great rest your day!
Posted Mar 27, 2017 - 15:25 UTC
Identified
We've identified the cause and hope to have a fix by EOD (US business hours). Please get in touch if you need help with making a purchase or upgrading your plan in the meantime.
Posted Mar 27, 2017 - 08:11 UTC
Investigating
We're having trouble with processing Amex cards - purchasing new subscriptions, upgrading, and automatic renewals may not be possible. We're working to get this resolved at the earliest. We're sorry for the trouble and will keep you updated!
Posted Mar 26, 2017 - 07:34 UTC