Investigating issues with dashboards loading slowly

Incident Report for Geckoboard

Resolved

The incident related to dashboards loading slowly is now resolved. Thank you for your patience.
Please get in touch with us at support@geckoboard.com if you experience any further issues.
Posted Oct 28, 2024 - 15:40 UTC

Investigating

We are currently investigating issues with dashboards loading slowly. We'll provide updates as we learn more.
Posted Oct 28, 2024 - 14:43 UTC
This incident affected: Web Application.