Email Snapshot Delivery Issues

Incident Report for Geckoboard

Resolved

We believe this issue has now been resolved, and all Microsoft Outlook users should be receiving their dashboard snapshots as expected.
Posted Dec 17, 2024 - 17:09 UTC

Monitoring

We're continuing to monitor the situation
Posted Dec 17, 2024 - 11:27 UTC

Investigating

We're aware that some scheduled email snapshots are not being delivered due to an issue with our email provider. One of their IP addresses has been flagged as spam by Microsoft Outlook. We're working closely with our provider to resolve this as quickly as possible. We apologize for the inconvenience and will update you as soon as we have more information.
Posted Dec 16, 2024 - 16:14 UTC