We are investigating an issue with the sign-up page

Incident Report for Geckoboard

Resolved

The service incident related to the sign-up page is now resolved. Thank you for your patience.
Please get in touch with us at support@geckoboard.com if you experience any further issues.
Posted Jul 15, 2025 - 10:53 UTC

Investigating

We are currently investigating issues with the sign-up page that is preventing users from starting a trial. We'll provide updates as we learn more.
Posted Jul 15, 2025 - 10:41 UTC