The incident involving Slack connections has now been resolved. Thank you for your patience. Please contact us at support@geckoboard.com if you need any further assistance.
Posted Mar 17, 2026 - 14:55 UTC
Monitoring
We've released an update to resolve the issues with Slack connections and are continuing to monitor the situation. We will provide further updates as they are available.
Posted Mar 17, 2026 - 14:34 UTC
Investigating
We are currently investigating an issue preventing users from creating new Slack connections. We'll provide updates as we learn more.