Widget Updates Delayed

Incident Report for Geckoboard

Resolved

Widgets are now updating as expected.

Please email us at support@geckoboard.com, or contact us within the App, if you experience any trouble with your widgets. Thank you for your patience!
Posted Aug 05, 2025 - 17:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2025 - 16:09 UTC

Investigating

We are investigating an issue with delayed widget updates and will provide updates as we learn more.
Posted Aug 05, 2025 - 16:06 UTC
This incident affected: Web Application.