Service incident related to Spreadsheets is now resolved. Thank you for your patience. Please contact us at support@geckoboard.com if you experience any further issues.
Posted Jun 19, 2026 - 16:42 UTC
Monitoring
We've released an update to resolve the issues with the Spreadsheets widgets. We'll continue monitoring the situation and update you shortly
Posted Jun 19, 2026 - 16:28 UTC
Investigating
We are currently investigating issues with Spreadsheets widgets. We'll provide updates as we learn more.