Widgets not refreshing

Incident Report for Geckoboard

Resolved

The incident related to widgets not refreshing is now resolved. Please contact us at support@geckoboard.com if you need help going forward.
Posted Aug 13, 2024 - 15:05 UTC

Investigating

We are currently investigating issues with widgets not refreshing as expected. We'll provide updates as we learn more.
Posted Aug 13, 2024 - 14:58 UTC
This incident affected: Web Application.