Investigating issues with accessing Geckoboard

Incident Report for Geckoboard

Resolved

The service incident related to account access is now resolved. Thank you for your patience.
Please contact us at support@geckoboard.com if you need any further help.
Posted Mar 19, 2025 - 15:20 UTC

Monitoring

We've released an update to resolve the issues with accessing Geckoboard. We'll continue monitoring the situation and update you shortly.
Posted Mar 19, 2025 - 14:31 UTC

Investigating

We are currently investigating issues with Geckoboard accounts being inaccessible. We'll provide updates as we learn more.
Posted Mar 19, 2025 - 13:58 UTC
This incident affected: Web Application.