Investigating issues when inviting users to view specific dashboards
Incident Report for Geckoboard
Resolved
The service incident related to inviting users to view specific dashboards is now resolved. Thank you for your patience.
Please contact us at support@geckoboard.com if you experience any further issues.
Posted Mar 19, 2020 - 19:05 UTC
Monitoring
We've released an update to resolve the issues when inviting users to view specific dashboards. We'll continue monitoring the situation and update you again soon.
Posted Mar 19, 2020 - 18:25 UTC
Investigating
We are currently investigating why some customers are experiencing issues when inviting users to view specific dashboards. We'll provide updates as we learn more.
Posted Mar 19, 2020 - 17:09 UTC