Investigating issues with password resets

Incident Report for Geckoboard

Resolved

This issue affecting password resets is now resolved. If you still experience any difficulties, please get in touch with our support team at support@geckoboard.com.
Posted Feb 23, 2026 - 10:41 UTC

Identified

We have identified the root cause of the password reset issue and are currently working on a solution.
Posted Feb 23, 2026 - 09:29 UTC

Investigating

We are currently investigating issues with password resets. We'll provide updates as we learn more.
Posted Feb 23, 2026 - 09:13 UTC