Some widgets intermittently failing to load
Incident Report for
Geckoboard
Resolved
Our investigation found no ongoing issue, and we’re closing this alert. We apologise for any confusion and appreciate your patience.
Posted
Sep
22
,
2026
-
10:49
UTC
Investigating
We are currently investigating intermittent errors in some widgets. We'll provide updates as we learn more.
Posted
Sep
22
,
2026
-
10:13
UTC
×
Subscribe to Incident
Subscribe to updates for
Some widgets intermittently failing to load
via . You'll receive .