Geckoboard app failing to load

Incident Report for Geckoboard

Resolved

We have resolved the issue that was preventing the app from loading for some users. If you are experiencing any additional issues, please reach out to our Support team at support@geckoboard.com.
Posted Nov 07, 2025 - 20:33 UTC

Monitoring

A fix has been implemented, and the application is now reloading as expected. We are continuing to monitor the results and will provide further updates shortly.
Posted Nov 07, 2025 - 17:33 UTC

Investigating

We are currently investigating an issue that is preventing the app from loading for some users. We will provide further updates as more information becomes available.
Posted Nov 07, 2025 - 17:21 UTC
This incident affected: Web Application.