Investigating issues with Shared Links
Incident Report for Geckoboard
Resolved
Problem solved! If you’re still having any issues, please message us for help at support@geckoboard.com.
Posted Nov 12, 2019 - 17:28 UTC
Monitoring
We've released an update to resolve the issues with Shared Links. We'll continue monitoring the situation and update you shortly
Posted Nov 12, 2019 - 15:11 UTC
Investigating
We are currently investigating issues with Shared Links not working/displaying a blank screen. We'll provide updates as we learn more.
Posted Nov 12, 2019 - 14:20 UTC