Identified issues affecting HubSpot, Aircall and Pipedrive refresh times

Incident Report for Geckoboard

Resolved

Service incident affecting HubSpot, Aircall and Pipedrive refresh times is now resolved.
Please contact us at support@geckoboard.com if you experience any further issues.
Posted Apr 30, 2026 - 14:09 UTC

Identified

We have identified the root cause of the issue affecting HubSpot, Aircall and Pipedrive refresh times
Posted Apr 30, 2026 - 13:43 UTC
This incident affected: Web Application.