Investigating issues with widgets taking a long time to load
Incident Report for Geckoboard
Resolved
Problem solved. Please carry on using Geckoboard as normal. If you’re still having any issues, please message us for help at support@geckoboard.com.
Posted Mar 24, 2020 - 12:53 UTC
Investigating
We are working on fixing up the issues with some widgets taking a long time to load/displaying errors. We will send you further updates on this as soon as possible.
Posted Mar 24, 2020 - 12:33 UTC