Issues with widgets failing to load

Incident Report for Geckoboard

Resolved

Most dashboards and widgets have now successfully reloaded and are updating again as expected. There may be a short delay while spreadsheet service connections are re-authenticated.

Please email us at support@geckoboard.com, or contact us within the App, if you experience any continued trouble with dashboards or widgets failing to load properly. Thank you for your patience!
Posted Jun 17, 2025 - 21:37 UTC

Monitoring

A fix has been implemented for widgets that were failing to load. We are monitoring the behavior, and dashboards will be back online shortly.
Posted Jun 17, 2025 - 21:16 UTC

Identified

We have identified the issue affecting widgets that are failing to load, and we are in the process of applying a solution. We will continue to post updates here as they are available.
Posted Jun 17, 2025 - 21:09 UTC

Investigating

We are currently investigating issues with widgets failing to load.

We'll provide updates as we learn more.
Posted Jun 17, 2025 - 20:26 UTC
This incident affected: Web Application.