Investigating issues with updating widgets
Incident Report for Geckoboard
Resolved
The issue is now resolved. Please contact us at support@geckoboard.com if you experience any further issues.
Posted Jul 19, 2019 - 15:04 UTC
Investigating
We're still working on fixing up the issues with updating widgets. We will send you further updates on this as soon as possible.
Posted Jul 19, 2019 - 14:35 UTC