Issues with Geckoboard integrations

Incident Report for Geckoboard

Resolved

The earlier outage affecting our cloud provider should be fully resolved, and all systems are back to normal. We're sorry for the disruption to your day. We’ll continue monitoring closely, but if you notice anything unusual, please don't hesitate to get in touch.
Posted Oct 20, 2025 - 12:03 UTC

Monitoring

Services are gradually coming back online following the earlier outage affecting our cloud provider. We’re closely monitoring everything as systems recover. If you’re still experiencing any issues, please feel free to email us at support@geckoboard.com
Posted Oct 20, 2025 - 09:30 UTC

Identified

We’re currently impacted by a major outage affecting our cloud provider, which is disrupting parts of our platform, customer support channels, and other parts of the internet. We'll keep you updated.
Posted Oct 20, 2025 - 07:20 UTC
This incident affected: Web Application, Support team chat tool, and Support team message delivery.