Investigating issues with dashbords displaying blank

Incident Report for Geckoboard

Identified

We have identified the issue preventing some dashboards from loading correctly, and our team is working on a fix. We'll provide further updates as we have more information.
Posted Aug 28, 2026 - 15:27 UTC

Investigating

We’re investigating an issue affecting some customers in which dashboards may appear blank.

Our team is actively working to identify the cause and restore normal dashboard functionality. We’ll provide another update as soon as we have more information.
Posted Aug 28, 2026 - 13:39 UTC
This incident affects: Web Application.