Investigating issues with Jira Cloud widgets

Incident Report for Geckoboard

Resolved

The issue affecting Jira Cloud widgets is now resolved. Thank you for your patience. If you experience any further issues, please reach out to our Customer Success team at support@geckoboard.com, and we'll be happy to help further.
Posted Aug 27, 2025 - 09:08 UTC

Investigating

We’re currently investigating an issue affecting Jira Cloud widgets. Our team is working on a fix and we’ll share updates as soon as possible.
Posted Aug 26, 2025 - 10:07 UTC